PATA1006 Sign In and Sign Out

版权声明:版权归原作者CangyeChen所有,未经原作者允许不得转载本文内容,否则将视为侵权,转载或者引用本文内容请注明来源及原作者,对于不遵守此声明或者其他违法使用本文内容者,本人依法保留追究权等 https://blog.csdn.net/CANGYE0504/article/details/88827830

PATA1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
#include<cstdio>
#include<iostream>
using namespace std;
struct pNode{
	char ID[20];
	int hh;
	int mm;
	int ss;
} temp,ans1,ans2;

bool compare(pNode node1,pNode node2)
{
	if(node1.hh!=node2.hh) return node1.hh>node2.hh;
	if(node1.mm!=node2.mm) return node1.mm>node2.mm;
	return node1.ss>node2.ss;
}

int main()
{
	ans1.hh=23;
	ans1.mm=59;
	ans1.ss=59;
	ans2.hh=00;
	ans2.mm=00;
	ans2.ss=00;
	int N;
	cin>>N;
	for(int i=0;i<N;i++)
	{
		scanf("%s %d:%d:%d",temp.ID,&temp.hh,&temp.mm,&temp.ss);
		if(compare(temp,ans1)==false)
		{
			ans1 = temp;
		}
		scanf("%d:%d:%d",&temp.hh,&temp.mm,&temp.ss);
		if(compare(temp,ans2)==true)
		{
			ans2 = temp;
		}
		
	}
	
	printf("%s %s\n",ans1.ID,ans2.ID);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/CANGYE0504/article/details/88827830