1006 Sign In and Sign Out (25 分)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/weixin_42582136/article/details/102640741

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin>>n;
    string id,in,out,sign_out="00:00:00",sign_in="23:59:59",name1,name2;
    for(int i=0;i<n;i++){
        cin>>id>>in>>out;
        if(in<=sign_in){
            sign_in=in;
            name1=id;
        }
        if(out>=sign_out){
            sign_out=out;
            name2=id;
        }
    }
    cout<<name1<<" "<<name2;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42582136/article/details/102640741