1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

AC参考代码:
#include<iostream>
#include<string.h>
#include <fstream>

using namespace std;
 
 
int main()
{
	//ifstream cin("1.txt");
    string names[1001],signIn[1001],signOut[1001],min,max,name,name1;
    int M;
 
    cin>>M;
    cin>>name>>min>>max;
    name1 = name;
    for(int i=1; i<M; i++)
    {
        cin>>names[i]>>signIn[i]>>signOut[i];
        if(strcmp(signIn[i].c_str(),min.c_str()) <= 0)
        {
            min = signIn[i];
            name = names[i];
        }
        if(strcmp(signOut[i].c_str(),max.c_str()) >= 0)
        {
            max = signOut[i];
            name1  = names[i];
        }
    }
    cout<<name<<" "<<name1<<endl;
    return 0;
}


索引都是一一对应的,设置初始最大值和最小值,找数组中的最值问题,一次遍历完成

水水过了~~~

猜你喜欢

转载自zjuerlemon.iteye.com/blog/2240100