团体天梯 L2-022 重排链表 (25 分)

版权声明:有疑问请在评论区回复,邮箱:[email protected] https://blog.csdn.net/qq_40946921/article/details/86600387

L2-022 重排链表 (25 分)

给定一个单链表 L​1​​→L​2​​→⋯→L​n−1​​→L​n​​,请编写程序将链表重新排列为 L​n​​→L​1​​→L​n−1​​→L​2​​→⋯。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。

输入格式:

每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤10​5​​)。结点的地址是5位非负整数,NULL地址用−1表示。

接下来有N行,每行格式为:

Address Data Next

其中Address是结点地址;Data是该结点保存的数据,为不超过10​5​​的正整数;Next是下一结点的地址。题目保证给出的链表上至少有两个结点。

输出格式:

对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

输出样例:

68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1
#include<iostream>
#include<list>
#include<vector>
#include<map>
struct T {
	int ads, data, next;
};
using namespace std;
int main() {
	map<int, T> mymap;
	list<T> mylist;
	vector<T> relist;
	int start, n, ads, data, next;
	cin >> start >> n;
	for (int i = 0; i < n; i++) {
		scanf("%d%d%d", &ads, &data, &next);
		mymap[ads] = { ads,data,next };
	}
	while (start != -1) {
		mylist.push_back(mymap[start]);
		start = mymap[start].next;
	}
	while (!mylist.empty()) {
		relist.push_back(mylist.back());	mylist.pop_back(); //尾元素
		if (mylist.empty()) break;
		relist.push_back(mylist.front());	mylist.pop_front(); //首元素
	}
	for (int i = 0; i < relist.size() - 1; i++)    //输出
		printf("%05d %d %05d\n", relist[i].ads, relist[i].data, relist[i + 1].ads);
	printf("%05d %d -1\n", relist.back().ads, relist.back().data);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40946921/article/details/86600387