L2-012 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

分析:必须注意,因为题目要求按照插入的顺序建立,所以是边插入边调整的,必须用向上调整,每次输入一个数之后就将它向上调整。(两者建立出来的二叉树不同)而不能采用先转换为二叉树的方式再向下调整。

#include<bits/stdc++.h>

using namespace std;
const int N=1010;
int head[N];
int cnt;
void Create(int x){
    head[++cnt] = x;
    int i=cnt;
    int j=i/2;
    while(j>=1){
        if(head[j]>head[i]){
            swap(head[j],head[i]);
            i=j;
            j=i/2;
        }
        else break;
    }
}
int main()
{
    int n,m;
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++){
        int x;
        scanf("%d",&x);
        Create(x);
    }
   while(m--){
        int a;
        char t[20],c[20];
        scanf("%d %s",&a,t);
        if(t[0]=='a'){
            int b;
            scanf("%d",&b);
            scanf("%s",t);
            scanf("%s",t);
            int id=0;
            for(int i=1;i<=n;i++){
                if(a==head[i]){
                    id=i;
                    break;
                }
            }
            id/=2;
            if(head[id*2]==b||head[id*2+1]==b){
                puts("T");
            }
            else puts("F");
        }
        else{
            scanf("%s",t);
            if(t[0]=='a'){
                scanf("%s",t);
                scanf("%s",t);
                int b;
                scanf("%d",&b);
                int id=0;
                for(int i=1;i<=n;i++){
                    if(a==head[i]){
                        id=i;
                        break;
                    }
                }
                if(head[id/2]==b){
                    puts("T");
                }
                else puts("F");
            }
            else{
                scanf("%s",t);
                if(t[0]=='r'){
                    if(head[1]==a) puts("T");
                    else puts("F");
                }
                else{
                    scanf("%s",t);
                    int b;
                    scanf("%d",&b);
                    int id=0;
                    for(int i=1;i<=n;i++){
                        if(b==head[i]){
                            id=i;
                            break;
                        }
                    }
                    if(head[id/2]==a) puts("T");
                    else puts("F");

                }
            }

        }

   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/CC_1012/article/details/88068393