7-3 关于堆的判断(25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T
#include <iostream>
#include <algorithm>
#include <string.h>
#include <string>
#include <math.h>
using namespace std;

int n,m;

const int MAX_V = 1001;

int heap[MAX_V],sz=0;

void push(int x){
	int i = sz++;
	while(i>0){
		int p = (i-1)/2;
		if(heap[p]<=x)	break;
		heap[i] = heap[p];
		i = p;
	}
	heap[i] = x;
}

int find(int x){
	for(int i=0;i<n;i++){
		if(heap[i]==x)
			return i;
	}
	return -1;
}

int main(){
	
	cin>>n>>m;
	
	for(int i=0;i<n;i++){
		int a;
		cin>>a;
		push(a);
	}
	
	string s;
	
	int x1,x2;
	
	for(int i=0;i<m;i++){
		cin>>x1;
		cin>>s;
		if(s=="and"){
			cin>>x2;
			cin>>s;
			cin>>s;
			
			if((find(x1)-1)/2==(find(x2)-1)/2){
				cout<<"T"<<endl;
			}
			else{
				cout<<"F"<<endl;
			}
		}
		else{
			cin>>s;
			if(s=="a"){
				cin>>s;
				cin>>s;
				cin>>x2;
				if(find(x2)*2+2>=find(x1)&&find(x1)>=find(x2)*2+1){
					cout<<"T"<<endl;
				}
				else{
					cout<<"F"<<endl;
				}
			}
			else{
				cin>>s;
				if(s=="root"){
					if(find(x1)==0){
						cout<<"T"<<endl;
					}
					else{
						cout<<"F"<<endl;
					}
				}
				else{
					cin>>s;
					cin>>x2;
					if(find(x1)*2+2>=find(x2)&&find(x2)>=find(x1)*2+1){
						cout<<"T"<<endl;
					}
					else{
						cout<<"F"<<endl;
					}	
				}
			}
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41700374/article/details/82020908
今日推荐