L2-012 关于堆的判断(25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • “x is the root”:x是根结点;
  • “x and y are siblings”:x和y是兄弟结点;
  • “x is the parent of y”:x是y的父结点;
  • “x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T
代码:
#include<bits/stdc++.h>
using namespace std;
int heap[1010],cnt=0;
char s[50];
map<int,int> Map;
void create(int x)
{
    heap[++cnt]=x;
    int t=cnt;
    while(t>1&&heap[t/2]>heap[t])
    {
        heap[t]=heap[t/2];
        heap[t/2]=x;
        t/=2;
    }
    heap[t]=x;
}
int main()
{
    int i,j,n,m,k,t,y;
    string s1;
    scanf("%d %d",&n,&m);
    char str[10];
    for(i=1;i<=n;i++)
    {
        scanf("%d",&k);
        create(k);
    }
    for(i=1;i<=n;i++)
    {
       Map[heap[i]]=i;
    }
    for(i=1;i<=m;i++)
    {
        scanf("%d %s",&t,str);
        if(str[0]=='a')
        {
           scanf("%d",&y);
           getline(cin,s1);//gets(s);为是么不行求指教。报错error: ‘gets’ was not declared in this scope
           if(Map[t]/2==Map[y]/2)
           {
               printf("T\n");
           }
           else
           {
               printf("F\n");
           }
        }
        else
        {
            scanf("%s %s",s,str);
            if(str[0]=='r')
            {
                if(Map[t]==1)
                {
                    printf("T\n");
                }
                else
                {
                    printf("F\n");
                }
            }
            else if(str[0]=='p')
            {
              scanf("%s %d",s,&y);
              if(Map[y]/2==Map[t])
              {
                  printf("T\n");
              }
              else
              {
                  printf("F\n");
              }
            }
            else if(str[0]=='c')
            {
                scanf("%s %d",s,&y);
                if(Map[y]==Map[t]/2)
              {
                  printf("T\n");
              }
              else
              {
                  printf("F\n");
              }
            }
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/guoqingshuang/article/details/80519835