Brackets (POJ-2955)

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
Sample Output

6
6
4
0
6

题意:求字符串中括号的最大匹配数。
思路:典型的区间dp问题,算是一道模版题。长度从1~str.size()中在str[0]~str[str.size() - 1]进行区间枚举,然后在l~r中间枚举位置进行dp值的更新。

#pragma once
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <iterator>
#include <sstream>
#include <fstream>
#include <list>
#define MST(a, b) memset(a, b, sizeof a);
using namespace std;
typedef long long ll;
const int MAXN = 100 + 10;
string str;
bool check(int a, int b) {
    if (str[a] == '(' && str[b] == ')') return true;
    else if (str[a] == '[' && str[b] == ']') return true;
    else return false;
}
int dp[MAXN][MAXN];
int main() {
    while (cin >> str) {
        if (str == "end") break;
        MST(dp, 0);
        for (int len = 1; len < str.size(); len++)
            for (int l = 0, r = l + len; r < str.size(); l++, r++) {
                if (check(l, r)) dp[l][r] = dp[l + 1][r - 1] + 2;
                for (int s = l; s < r; s++) {
                    dp[l][r] = max(dp[l][r], dp[l][s] + dp[s + 1][r]);
                }
            }
        cout << dp[0][str.size() - 1] << endl;
    }
}

猜你喜欢

转载自blog.csdn.net/white_yasha/article/details/80642639