码 博弈 UVALive-7725 Game of Taking Stones 大数 Java

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=5747

Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.

Now, giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?

Input

Input contains multiple sets of test data.Each test data occupies one line, containing two non-negative integers a and b, representing the number of two stones. a and b are not more than 10100 .

Output

For each test data, output answer on one line. ‘1’ means you are the winner, otherwise output ‘0’.

Sample Input

2 1

8 4

4 7

Sample Output

0

1

0

留白2333

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        BigDecimal TWO = BigDecimal.valueOf(2);
        BigDecimal FIVE= BigDecimal.valueOf(5);
        BigDecimal EPS = new BigDecimal(
"-0.0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");
        BigDecimal l = new BigDecimal("2.2360679774997");
        BigDecimal r = new BigDecimal("2.2360679774998");
        BigDecimal mid=null;

        //二分求sqrt(5)
        while (l.subtract(r).compareTo(EPS) < 0) {
            mid = l.add(r).divide(TWO);//mid = (l+r)>>1;
            if (mid.multiply(mid).subtract(FIVE).abs().compareTo(EPS.abs()) < 0) break;
            if (mid.multiply(mid).subtract(FIVE).compareTo(EPS) < 0) l = mid;
            else r = mid;
        }

        BigDecimal GOLD = mid.add(BigDecimal.ONE).divide(TWO);
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()) {
            BigDecimal a = sc.nextBigDecimal();
            BigDecimal b = sc.nextBigDecimal();
            if(a.compareTo(b)>0){
                BigDecimal t=a;a=b;b=t;
            }
            BigDecimal c=b.subtract(a).setScale(0,BigDecimal.ROUND_FLOOR).multiply(GOLD);
            c=c.setScale(0,BigDecimal.ROUND_FLOOR);
            if(a.equals(c)) System.out.println("0");
            else System.out.println("1");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/DADDY_HONG/article/details/82927646
今日推荐