Game of Connections(java 大数类)

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, … , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. And, no two segments are allowed to intersect.

It’s still a simple game, isn’t it? But after you’ve written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?
Input
Each line of the input file will be a single positive number n, except the last line, which is a number -1. You may assume that 1 <= n <= 100.
Output
For each n, print in a single line the number of ways to connect the 2n numbers into pairs.
Sample Input
2
3
-1
Sample Output
2
5
题意:
问你2N个数围成一个圈,可以组成多少个不相交的对
解题思路:
该规律满足卡特兰数。直接利用递推公式h(n)=h(n-1)*(4*n-2)/(n+1);
代码:

import java.*;
import java.math.BigInteger;
import java.util.Scanner;
public class 大数测试 {
    public static void main(String[] args)
    {
        Scanner cin =new Scanner(System.in);
        BigInteger[] a= new BigInteger[101];
        a[1]=new BigInteger("1");
        for(int i=2;i<101;i++)
        {
            a[i]=a[i-1].multiply(new BigInteger(String.format("%d",4*i-2))).
            divide(new BigInteger( String.format("%d", i+1)));
        }
        while (cin.hasNext()) {
            int n=cin.nextInt();
            if(n==-1)
                break;
            System.out.println(a[n]);
        }

    }

}

猜你喜欢

转载自blog.csdn.net/gee_zer/article/details/81215181
今日推荐