A New Stone Game (博弈)

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output

For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

题目大意:对于n堆石子,每堆若干个,两人轮流操作,每次操作分两步,第一步从某堆中去掉至少一个,第二步(可省略)把该堆剩余石子的一部分分给其它的某些堆。最后谁无子可取即输。

分析:

如果只有一堆石子,先手必胜态。

如果有两堆石子,并且两堆石子的数量相等,那么先手采取什么样的策略,后手采取一样的策略,先手必败态。

如果有三堆石子,那么先手可以在第一步取到只剩两堆相同数量的石子,先手必胜。

如果有四堆石子,由于三堆石子是必胜态,所以只要逼对方取完某一堆石子,而只有在四堆石子都为1时,才能迫使某一方取完一堆石子,

只有当四堆石子可以分成两两相等的两队时,先手必败。

总结:

当n为偶,且可以分成n/2对两两相等的石子时,先手必败,否则先手必胜。

代码:

    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    int main () 
	{
     	int s[20],i,n;
    	while(scanf("%d",&n)!=EOF) 
		{
			if(n==0)
				break;
    		for(i=0;i<n;i++)
    			scanf("%d",&s[i]);
    		if(n%2)
    			printf ("1\n");
    		else{
    			sort(s,s+n);
    			for(i=0;i<n;i=i+2)
    				if(s[i]!=s[i+1])
    					break;
    			//printf("i---%d,n---%d\n",i,n);
    			if(i==n)
    				printf ("0\n");
    			else
    				printf("1\n");
    		}
    	}
    	return 0;
    }

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81111888