Game of Taking Stones HDU - 5973(java高精度二分开根号+威佐夫博弈)

Game of Taking Stones HDU - 5973

 Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy? 

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
Sample Input

2 1
8 4
4 7

Sample Output

0
1
0

裸威佐夫博弈,但数据范围大,用java
精确到小数点后100位
code:

import java.math.BigDecimal;
import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        BigDecimal TWO = BigDecimal.valueOf(2);
        BigDecimal FIVE = BigDecimal.valueOf(5);
        BigDecimal EPS = new BigDecimal("-0.0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");   
        BigDecimal l = new BigDecimal("2.2360679774997");
        BigDecimal r = new BigDecimal("2.2360679774998");
        BigDecimal mid = null;
        while(l.subtract(r).compareTo(EPS) < 0) {
            mid = l.add(r).divide(TWO);
            if(mid.multiply(mid).subtract(FIVE).abs().compareTo(EPS.abs()) < 0) break;
            if(mid.multiply(mid).subtract(FIVE).compareTo(EPS) < 0) l = mid;
            else r = mid;
        }
        BigDecimal GOLD = mid.add(BigDecimal.ONE).divide(TWO);

        Scanner cin = new Scanner(System.in);
        while(cin.hasNext()) {
            BigDecimal a = cin.nextBigDecimal();
            BigDecimal b = cin.nextBigDecimal();
            if(a.compareTo(b) > 0) {
                BigDecimal t = a;
                a = b;
                b = t;
            }
            BigDecimal c = b.subtract(a).setScale(0, BigDecimal.ROUND_FLOOR).multiply(GOLD);
            c = c.setScale(0,BigDecimal.ROUND_FLOOR);
            if(a.equals(c)) System.out.println("0");
            else System.out.println("1");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81151949
今日推荐