PAT 1036 Boys vs Girls

 This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

 Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

 For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
struct Node
{
    string Name;
    string Gender;
    string Number;
    int grade;
};
bool Compare(Node x,Node y)
{
    return x.grade<y.grade;
}
int main()
{
    int N;
    scanf("%d",&N);
    vector<Node> Male;
    vector<Node> Female;
    Node x;
    for(int i=0; i<N; i++)
    {
        cin>>x.Name>>x.Gender>>x.Number>>x.grade;
        if(x.Gender=="M")
            Male.push_back(x);
        else
            Female.push_back(x);
    }
    sort(Male.begin(),Male.end(),Compare);
    sort(Female.begin(),Female.end(),Compare);
    if(Male.empty()||Female.empty())
    {
        if(Male.empty()&&!Female.empty())
        {
            int index=Female.size();
            cout<<Female[index-1].Name<<' '<<Female[index-1].Number<<endl;
            cout<<"Absent"<<endl;
            cout<<"NA";
        }
        else if(!Male.empty()&&Female.empty())
        {
            cout<<"Absent"<<endl;
            cout<<Male[0].Name<<' '<<Male[0].Number<<endl;
            cout<<"NA";
        }
        else if(Male.empty()&&Female.empty())
        {
            cout<<"Absent"<<endl;
            cout<<"Absent"<<endl;
            cout<<"NA";
        }
    }
    else
    {
        int index=Female.size();
        cout<<Female[index-1].Name<<' '<<Female[index-1].Number<<endl;
        cout<<Male[0].Name<<' '<<Male[0].Number<<endl;
        cout<<Female[index-1].grade-Male[0].grade;
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/84778005