【PAT 甲级】1036 Boys vs Girls (25)

题目链接

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade~F~-grade~M~. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

思路:模拟

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <stack>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N = 1e5+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;
const int T=3;

int main() {
    int n;
    cin>>n;
    int fmax=-INF,mmin=INF;
    string mansName,mansId,fansName,fansId;
    for(int i=0; i<n; i++) {
        int score;
        string name,id,ch;
        cin>>name>>ch>>id>>score;
        if(ch=="M") {
            if(score<mmin) {
                mmin=score;
                mansName=name;
                mansId=id;
            }
        } else {
            if(score>fmax) {
                fmax=score;
                fansName=name;
                fansId=id;
            }
        }
    }
    int diff;
    if(fmax!=-INF&&mmin!=INF) {
        diff=fmax-mmin;
    } else {
        diff=-1;
    }
    if(fmax!=-INF) {
        cout<<fansName<<" "<<fansId<<endl;
    } else {
        cout<<"Absent\n";
    }
    if(mmin!=INF) {
        cout<<mansName<<" "<<mansId<<endl;
    } else {
        cout<<"Absent\n";
    }
    if(diff!=-1) {
        cout<<diff;
    } else {
        cout<<"NA";
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81174920