PAT (Advanced Level) Practice 1036 Boys vs Girls

版权声明:copyright©CodeIover reserved https://blog.csdn.net/qq_40073459/article/details/86492843

                                     1036 Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

running code:

#include<cstdio>
struct Student{
  char name[11],ID[11];
  char gender;
  int grade;
}temp,Mlowest,Fhighest;
int main()
{
  Mlowest.grade=101;
  Fhighest.grade=-1;
  int N;
  scanf("%d",&N);
  for(int i=0;i<N;i++)
  {
    scanf("%s %c %s %d",temp.name,&temp.gender,temp.ID,&temp.grade);
    if(temp.gender=='M'&&temp.grade<Mlowest.grade) Mlowest=temp;
    if(temp.gender=='F'&&temp.grade>Fhighest.grade) Fhighest=temp;
   }
   if(Fhighest.grade==-1) printf("Absent\n");
   else printf("%s %s\n",Fhighest.name,Fhighest.ID);
   if(Mlowest.grade==101) printf("Absent\n");
   else printf("%s %s\n",Mlowest.name,Mlowest.ID);
   if(Fhighest.grade!=-1&&Mlowest.grade!=101) printf("%d",Fhighest.grade-Mlowest.grade);
   else printf("NA");
   return 0;
}

result:

sample 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Mary EE990830
Joe Math990112
6

sample 2:

1
Jean M AA980920 60
Absent
Jean AA980920
NA

猜你喜欢

转载自blog.csdn.net/qq_40073459/article/details/86492843