[ PAT-A ] 1036 Boys vs Girls (C++)

题目描述

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade~F~-grade~M~. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA


解题思路

题目大意
给定一组考生信息(包含name gander id grade),从中选取男生中的最低分,女生中的最高分,并求他们成绩的差值
思路
题目很简单,在输入数据时,找到男生中的最低分,女生中的最高分,并存下他们的信息.之后进行输出即可


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
using namespace std;
// zhicheng
// August 18,2018
int main()
{
  int t,ml_grade=101,fh_grade=-1;string ml_id,fh_id,ml_name,fh_name;
  for(scanf("%d",&t);t;t--)
  {
    string id,na,ge;int gr;
    cin>>na>>ge>>id>>gr;
    if(ge=="M"&&gr<ml_grade) {ml_name=na;ml_id=id;ml_grade=gr;} // 男生中的最低分
    if(ge=="F"&&gr>fh_grade) {fh_name=na;fh_id=id;fh_grade=gr;} // 女生中的最高分
  }
  fh_grade!=-1?cout<<fh_name<<" "<<fh_id<<endl:cout<<"Absent\n"; // 判断是否有女生数据
  ml_grade!=101?cout<<ml_name<<" "<<ml_id<<endl:cout<<"Absent\n"; // 判断是否有男生数据
  fh_grade==-1||ml_grade==101?printf("NA\n"):printf("%d\n",fh_grade-ml_grade);// 输出他们成绩的差值
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

猜你喜欢

转载自blog.csdn.net/S_zhicheng27/article/details/81807254