1036 Boys vs Girls(25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

思路:用结构体分别存储男女生的信息,然后排序,输出最低年级的男生和最高年级的女生。 

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn = 110;//最大学生人数
struct fm
{
	string name;//姓名
	string id;//学生id
	int grade;//年级
}f[maxn], m[maxn];//F (female)女性高 or M (male)男性低
int cmp(fm a, fm b)//按年级从小到大排序
{
	return a.grade < b.grade;
}
int main()
{
	int n;
	cin >> n;
	int i, j;
	i = j = 0;
	string Name, Id, Gender;
	int Grade;
	int flag1, flag2;//标记,男生或女生的个数是否为0
	flag1 = flag2 = 0;
	for (int k = 0; k<n; k++)
	{
		cin >> Name >> Gender >> Id >> Grade;
		if (Gender[0] == 'M')
		{
			m[i].name = Name;
			m[i].id = Id;
			m[i].grade = Grade;
			i++;
			flag1 = 1;
		}
		else if (Gender[0] == 'F')
		{
			f[j].name = Name;
			f[j].id = Id;
			f[j].grade = Grade;
			j++;
			flag2 = 1;
		}
	}
	sort(f, f + j, cmp);//排序
	sort(m, m + i, cmp);	
	if (flag1 && flag2)//分情况输出
	{
		cout << f[j-1].name << " " << f[j-1].id << endl;
		cout << m[0].name << " " << m[0].id << endl;
		cout << f[j-1].grade - m[0].grade << endl;
	}
	else if (flag2 == 0)
	{
		cout << "Absent" << endl;
		cout << m[0].name << " " << m[0].id << endl;
		cout << "NA" << endl;
	}
	else if (flag1 == 0)
	{
		cout << f[j-1].name << " " << f[j-1].id << endl;
		cout << "Absent" << endl;
		cout << "NA" << endl;
	}	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Fcity_sh/article/details/84000308