【PAT】A1036. Boys vs Girls (25)

Description:
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100

Mary F EE990830 95


Sample Output 1:
Mary EE990830
Joe Math990112

6


Sample Input 2:
1

Jean M AA980920 60


Sample Output 2:
Absent
Jean AA980920

NA

//NKW 甲级练习题1011
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
typedef struct person{
	char name[11];
	char gender;
	char id[11];
	int grade;
}person;
person tp, tm, tf;
void set(){
	tm.grade = 101;
	tf.grade = -1;
}
int main(){
	set();
	int N, flag = 0;
	scanf("%d", &N);
	for (int i = 0; i < N; i++){
		scanf("%s %c %s %d", tp.name, &tp.gender, tp.id, &tp.grade);
		if (tp.gender == 'M'&&tp.grade < tm.grade)
			tm = tp;
		if (tp.gender == 'F'&&tp.grade > tf.grade)
			tf = tp;
	}
	if (tf.grade == -1){
		flag = 1;
		printf("Absent\n");
	}
	else
		printf("%s %s\n", tf.name, tf.id);
	if (tm.grade == 101){
		flag = 1;
		printf("Absent\n");
	}
	else
		printf("%s %s\n", tm.name, tm.id);
	if (flag == 1)
		printf("NA\n");
	else
		printf("%d\n", tf.grade - tm.grade);		//无需使用abs(),看题
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/80890616