PAT (Advanced Level) Practice 1036 Boys vs Girls (25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade~F~-grade~M~. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

C++:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
struct student{
	char name[11];  //字符数组名字就代表地址 
	char gender;
	char ID[11];
	int grade;
}stu,Fmax,Mmin;
int main(){
	int N;
	scanf("%d",&N);
	if(N==1){
		cin >> stu.name >> stu.gender >> stu.ID >> stu.grade;
		//scanf("%s%c%s%d",stu.name,&stu.gender,stu.ID,&stu.grade);	 //scanf字符串会有缓冲问题 
		if(stu.gender=='F'){
			cout << stu.name <<" "<< stu.ID << "\n" << "Absent" << "\n" << "NA" ; 
			//printf("%s %s\n",stu.name,stu.ID);
			//printf("%s\n","absent");
			//printf("%s\n","NA");
		}
		else{
			cout << "Absent" << "\n" << stu.name <<" "<< stu.ID << "\n" << "NA" ; 
			//printf("%s\n","absent");
			//printf("%s %s\n",stu.name,stu.ID);
			//printf("%s\n","NA");
		} 			
	}
	else{
		Fmax.grade=0;
		Mmin.grade=100; 
		int Fcount = 0;
		int Mcount = 0;
		for(int i=0;i<N;i++){
			cin >> stu.name >> stu.gender >> stu.ID >> stu.grade;
			if(stu.gender=='F'){  //strcmp 比较两个字符串 
				if(stu.grade>Fmax.grade){
					Fmax = stu ;
					Fcount++;
				}
			}
			else{
				if(stu.grade<Mmin.grade){
					Mmin = stu ;
					Mcount++;				
			    } 		
		   }			
	   }
	if(Fcount==0){
		cout << "Absent" << "\n" << Mmin.name <<" "<< Mmin.ID << "\n" << "NA" ; 
	}
	else if(Mcount==0){
		cout << Fmax.name <<" "<< Fmax.ID << "\n" << "Absent" << "\n" << "NA" ; 
	}
	else{
		cout << Fmax.name <<" "<< Fmax.ID << "\n" << Mmin.name <<" " << Mmin.ID << "\n" << Fmax.grade-Mmin.grade ;
	}
	
   }
   return 0;
}

注:

本题不可以用scanf 输入,因为对于字符串空格会被包含在里面,所以这里需要使用cin ,最好也使用对应的cout

还有一个地方就是粗心的了,absent首字母大写,一开始没有注意一直通不过,hiahiahia...

猜你喜欢

转载自blog.csdn.net/lili_code/article/details/80650781