Light-oj-1214(同余定理)

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	int count = 0;
	while(t--)
	{
		count++;
		char ch[350];
		long long int b;
		long long int res;
		res = 0;
		scanf("%s %lld",ch,&b);
		if(b<0)
			b = -b;
		int len = strlen(ch);
		for(int i = 0; i < len; i ++)
		{
			if(ch[i]=='-')
				continue;
			else
				res = (res*10+ch[i]-'0')%b;
                    //边改边模
		}
		res = res%b;
		printf("Case %d: ",count);
		if(res)
			printf("not divisible\n");
		else
			printf("divisible\n");
	}
}

猜你喜欢

转载自blog.csdn.net/qiulianshaonv_wjm/article/details/84470844