Light OJ 1214 Large Division (大数取模)

题目:

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10^200 ≤ a ≤ 10^200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

注:需要判断输入数字字符串a的首位为‘-’的情况和b为负数的情况。

代码:

#include <iostream>
#include <cstring>
using namespace std;
char a[100000];
int main()
{
	long long t,i,k,b,n,h;
	cin>>t;
	h=1;
	while(t--)
	{
		cin>>a;
		cin>>b;
		if(b<0) b=-b;
		n=strlen(a);
		if(a[0]=='-')
		{
			for(i=0;i<n-1;i++)
			{
				a[i]=a[i+1];
			}
			n--;
		}
		k=0;
		for(i=0;i<n;i++)
		{
			k=(k*10+a[i]-'0')%b;
		}
		cout<<"Case "<<h++<<": ";
		if(!k) cout<<"divisible"<<endl;
		else cout<<"not divisible"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/KK_2018/article/details/81209043