Hdu 1863 畅通工程

畅通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29603    Accepted Submission(s): 12986

Problem Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。

Output

对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。

Sample Input

3 3

1 2 1

1 3 2

2 3 4

1 3

2 3 2

0 100

Sample Output

3

?

#include <stdio.h>  
#include <algorithm>  
using namespace std;  
struct EDGE  
{  
    int u,v,cost;  
}eg[100001];  
int n,m,father[100001];  
  
bool cmp(EDGE e1,EDGE e2)  
{  
    return e1.cost<e2.cost;  
}  
  

void Init( int m )  
{  
    int i;  
    for(i=1;i<=m;i++)  
        father[i]=i;  
}    
int Find(int x)  
{  
    while(father[x]!=x)  
        x=father[x];  
    return x;  
}  

void Combine(int a,int b)  
{  
    int temp_a,temp_b;  
    temp_a=Find(a);  
    temp_b=Find(b);  
  
    if(temp_a!=temp_b)  
        father[temp_a]=temp_b;  
}  
  
// 最小生成树 Kruskal 算法  int Kruskal( void )  
{  
    EDGE e;  
    int i,res;  
    sort(eg,eg+n,cmp);  
   
    Init(m);  
  
  
    res=0;  
    for( i=0;i<n;++i )  
    {  
        e=eg[i];  
        if( Find(e.u)!=Find(e.v) )  
        {  
            Combine(e.u,e.v);  
            res+=e.cost;  
        }  
    }  
    return res;  
}  
  
int main()  
{  
    int i,ans;  
    bool bl;  
    while( scanf("%d%d",&n,&m) && n )  
    {  
        for( i=0;i<n;++i )  
            scanf("%d%d%d",&eg[i].u,&eg[i].v,&eg[i].cost);  
        ans=Kruskal();  
           
        bl=true;  
        for(i=2;i<=m;++i)  
            if( Find(1)!=Find(i) )  
            {  
                bl=false;  
                break;  
            }  
              
        if( bl )    printf("%d\n",ans);  
        else    printf("?\n");  
    }  
    return 0;  
} 

  

猜你喜欢

转载自blog.csdn.net/zhangliu463884153/article/details/80029403
今日推荐