POJ2955-Brackets(区间DP)

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6

分析:

题意:
给出一个字符串,求能够匹配的字符有多少,一个串中,一个字符与另外的字符匹配成一组,就不能再和其他的字符在进行匹配成一组!

解析:
这道题比较简单(相对于POJ1141这道题而言,POJ1141这道题能够解决,我相信这道题应该就很简单了:POJ1141).

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define N 105

using namespace std;

int dp[N][N];

bool cmp(char a,char b)
{
	if((a=='('&&b==')')||(a=='['&&b==']'))
		return true;
	return false;
}

int main()
{
	string str;
	while(cin>>str&&str!="end")
	{
		memset(dp,0,sizeof(dp));
		int len =str.length();
		for(int len1=2;len1<=len;len1++)
		{
			for(int i=1;i+len1-1<=len;i++)
			{
				int j=len1+i-1;
				if(cmp(str[i-1],str[j-1]))
					dp[i][j]=dp[i+1][j-1]+2;
				for(int k=i;k<j;k++)
				{
					dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
				}
			}
		}
		printf("%d\n",dp[1][len]);
	}
	return 0;
 }

猜你喜欢

转载自blog.csdn.net/weixin_43357583/article/details/105880177