1008 - How many N

版权声明:转载注明出处,大家一起交流 https://blog.csdn.net/qq_38231051/article/details/82291364

题目:

Problem Description

Find a minimal interger K which is merely comprised of N and can be divided by M.

For example,11 is the minimal number that and be divided by 11, and it is comprised of two '1's, and 111111 can be divided by 13 which is comprised of six '1's.

Input

On each line of input , there will be two positive integer, N and M. N is a digit number, M is no more than 10000.

Output

On each single line, output the number of N, if no such K, output zero.

Sample Input

1 5
1 11
1 13

Sample Output

0
2
6

先占个坑,等我搞懂原理回来补坑

ac代码

#include <stdio.h>
#include <stdlib.h>

int main()
{
    
    int n,m;
    
    while(scanf("%d%d",&n,&m)==2)
    {
        int num = n;
        int count = 1;

        while((num%m!=0)&&(count<=2*m))
        {

            num = 10 * (num % m) + n;
            count++;

        }
        if(count == 2*m+1)

            count=0;

        printf("%d\n",count);

    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_38231051/article/details/82291364