How Many Points? LightOJ - 1077

Given two points A and B on the X-Y plane, output the number of the lattice points on the segment AB. Note that A and B are also lattice point. Those who are confused with the definition of lattice point, lattice points are those points which have both x and y co-ordinate as integer.

For example, for A (3, 3) and B (-1, -1) the output is 5. The points are: (-1, -1), (0, 0), (1, 1), (2, 2) and (3, 3).


Input

Input starts with an integer T (≤ 125), denoting the number of test cases.

Each case contains four integers, Ax, Ay, Bxand By. Each of them will be fit into a 32 bit signed integer.

Output

For each test case, print the case number and the number of lattice points between AB.

Sample Input

2

3 3 -1 -1

0 0 5 2

Sample Output

Case 1: 5

Case 2: 2

#include <cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;

/*
要不是这道题挂在这里,我都不敢想gcd,感觉有点蒙
不过想一想确实 用在这里是蛮好的,gcd就是可以最多
分成几块,感觉很神奇
*/

ll gcd(ll a,ll b){
    return b==0?a:gcd(b,a%b);
}

int main()
{
    int T,kase=1;
    scanf("%d",&T);
    while(T--){
        ll ax,ay,bx,by;
        scanf("%lld %lld %lld %lld",&ax,&ay,&bx,&by);
        ll d1=abs(bx-ax),d2=abs(by-ay);
        if(d1>d2)swap(d1,d2);
        printf("Case %d: ",kase++);
        ll g=gcd(d1,d2);
        printf("%lld\n",g+1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/80244880