POJ 3264 Balanced Lineup (RMQ模板)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Tc_To_Top/article/details/82936284

Balanced Lineup

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 65283   Accepted: 30409
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

题目链接:http://poj.org/problem?id=3264

题目大意:求区间最大值减最小值

题目分析:RMQ模板题

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const MAX = 50005;
int n, q, l, r, a[MAX], ma[MAX][21], mi[MAX][21];

void Init_RMQ() {
    for (int i = 1; i <= n; i++) {
        ma[i][0] = mi[i][0] = a[i];
    }
    for (int j = 1; j <= 20; j++) {
        for (int i = 1; i + (1 << j) - 1 <= n; i++) {
            ma[i][j] = max(ma[i][j - 1], ma[i + (1 << (j - 1))][j - 1]);
            mi[i][j] = min(mi[i][j - 1], mi[i + (1 << (j - 1))][j - 1]);
        }
    }
}

int solve(int l, int r) {
    int k = (int)(log((double)(r - l + 1)) / log(2.0));
    return max(ma[l][k], ma[r - (1 << k) + 1][k]) - min(mi[l][k], mi[r - (1 << k) + 1][k]);
}

int main() {
    scanf("%d %d", &n, &q);
    for (int i = 1; i <= n; i++) {
        scanf("%d", &a[i]);
    }
    Init_RMQ();
    while (q--) {
        scanf("%d %d", &l, &r);
        printf("%d\n", solve(l, r));
    }
}

猜你喜欢

转载自blog.csdn.net/Tc_To_Top/article/details/82936284