Balanced Lineup Poj3264

Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 60228   Accepted: 28178
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

RMQ裸题,RMQ先n*log2(n)预处理,O(1)询问

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn = 50050;
int a[maxn];
int dpMax[maxn][25];
int dpMin[maxn][25];
void init(int n)   //dp预处理 dp[i][j] 表示以i为起点2^j长度的区间内的最值
{
    for(int i=1; i<=n; i++)dpMax[i][0]=dpMin[i][0]=a[i];
    for(int j=1; (1<<j)<=n; j++)
        for(int i=1; i+(1<<j)-1<=n; i++)
        {
            dpMax[i][j]=max(dpMax[i][j-1],dpMax[i+(1<<(j-1))][j-1]);
            dpMin[i][j]=min(dpMin[i][j-1],dpMin[i+(1<<(j-1))][j-1]);
        }
}
int getK(int len)  //(2^k<=len)得到最大的k
{
    int temp = 1;
    for(int i=0;;i++)
    {
        if(temp>len)
            return i-1;
        temp*=2;
    }
}
int queryMax(int l,int r)   //询问
{
    int k=trunc(getK(r-l+1));
    //int k=trunc(log2(r-l+1));
    return max(dpMax[l][k],dpMax[r-(1<<k)+1][k]);
}
int queryMin(int l,int r)
{
    int k=trunc(getK(r-l+1));
    return min(dpMin[l][k],dpMin[r-(1<<k)+1][k]);
}
int main()
{
    int n,q;
    scanf("%d%d",&n,&q);
    for(int i=1; i<=n; i++)
        scanf("%d",&a[i]);
    init(n);
    while(q--)
    {
        int l,r;
        scanf("%d%d",&l,&r);
        printf("%d\n",queryMax(l,r)-queryMin(l,r));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37804064/article/details/79955574