POJ3264 Balanced Lineup【RMQ】

Balanced Lineup

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 64936   Accepted: 30249
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

扫描二维码关注公众号,回复: 3192403 查看本文章

USACO 2007 January Silver

题目大意:给你一个数列,查询区间[l,r]的最大值和最小值的差值,RMQ模板题

AC的C++代码:

#include<iostream>
#include<cmath>

using namespace std;

const int N=50010;
int a[N],dpmax[N][30],dpmin[N][30];

void ST(int n)
{
	for(int i=1;i<=n;i++)
	  dpmax[i][0]=dpmin[i][0]=a[i];
	for(int j=1;(1<<j)<=n;j++)
	  for(int i=1;i+(1<<j)-1<=n;i++){
	  	  dpmax[i][j]=max(dpmax[i][j-1],dpmax[i+(1<<(j-1))][j-1]);
	  	  dpmin[i][j]=min(dpmin[i][j-1],dpmin[i+(1<<(j-1))][j-1]);
	  }
}

//查询数组a的[l,r]区间的最值 【倍增】RMQ的ST表算法
int RMQ_ST(int l,int r)
{
	int k=(int)(log((double)(r-l+1))/log(2.0));
	int maxval=max(dpmax[l][k],dpmax[r-(1<<k)+1][k]);
	int minval=min(dpmin[l][k],dpmin[r-(1<<k)+1][k]);
	return (maxval-minval);
}

int main()
{
	int n,q,l,r;
	scanf("%d%d",&n,&q);
	for(int i=1;i<=n;i++)
	  scanf("%d",&a[i]);
	ST(n);
	while(q--){
		scanf("%d%d",&l,&r);
		printf("%d\n",RMQ_ST(l,r));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/82595796