The number of divisors(约数) about Humble Numbers(约数个数公式)

The number of divisors(约数) about Humble Numbers

 A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
Output
For each test case, output its divisor number, one line per case.
Sample Input

4
12
0

Sample Output

3
6

裸的因数个数公式

code:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main(){
    ll n;
    while(~scanf("%lld",&n) && n){
        int p[] = {2,3,5,7};
        int a[] = {1,1,1,1};
        for(int i = 0; i < 4; i++){
            if(n % p[i] == 0){
                while(n % p[i] == 0){
                    a[i]++;
                    n /= p[i];
                }
            }
        }
        printf("%d\n",a[0]*a[1]*a[2]*a[3]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81218352