hdu2795Billboard 线段树点修改 求符合条件的下标

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28142    Accepted Submission(s): 11454

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5 2 4 3 3 3

Sample Output

1 2 1 3 -1

 

就是说给你一个h*w的矩形,每次你要填充1*x的矩形,顺序优先选择上左方填充。然后n是200000,如果扫一遍n^2就炸了,所以要用线段树记录最大值,优先从左子树寻找。找到之后更新并且返回rt (这里的找和更新合并了)

#include <iostream>
#include <cstdio>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

const int maxn = 222222;
int MAX[maxn <<2];
int h,w,n;

void PushUP(int rt){
    MAX[rt] = max(MAX[rt<<1],MAX[rt <<1|1]);
    return;
}
void build(int l,int r,int rt){
    MAX[rt] = w;
    if(l == r){
        return;
    }
    int m = (l + r)>>1;
    build(lson);
    build(rson);
}

int query(int x,int l,int r,int rt){//每次都是整个区间操作,所以可以合并update和query
    if(l == r){
        MAX[rt] -= x;
        return l;
    }
    int m = (l + r)>>1;
    int index;
    if(MAX[rt<<1] >= x){
        index = query(x,lson);
    }
    else{
        index = query(x,rson);
    }
    PushUP(rt);
    return index;
}

int main() {
    while(scanf("%d%d%d",&h,&w,&n) != EOF){
        if(h > n)h = n;
        build(1,h,1);
        while(n--){
            int x;
            scanf("%d",&x);
            if(MAX[1] < x)
                printf("-1\n");
            else
                printf("%d\n",query(x,1,h,1));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37136305/article/details/81482359
今日推荐