hdu 1087 Super Jumping! Jumping! Jumping! (动态规划)

题目描述:

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

题目分析:

在一串数中,寻找一组数值依次递增且和最大的一组数,并输出和。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    int n, max1,k;
    int a[1010], dp[1010];
    while(scanf("%d",&n)&&n)
    {
        memset(dp,0,sizeof(0));
        for(int i=1;i<=n;i++)
          cin>>a[i];
        for(int i=1;i<=n;i++)
        {
            max1=0;

            for(int j=0;j<i;j++)
              if(a[i]>a[j])
                max1=max(max1,dp[j]);
            dp[i]=max1+a[i];

        }
        k=0;
        for(int i=1;i<=n;i++)
        if(dp[i]>k)
            k=dp[i];
       printf("%d\n",k);
    }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/fanxingxue/article/details/82858404