HDOJ-1087 Super Jumping! Jumping! Jumping!(动态规划)

版权声明:个人学习笔记记录 https://blog.csdn.net/Ratina/article/details/84929510

链接:HDOJ-1087

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
在这里插入图片描述
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3


题目大意:
从左到右移动,每次只能移向更大的数字(或者end),求从start和end经过的数字之和的最大值。


状态转移方程:
dp[i] = max( dp[i] , a[j] < a[i] ? ( a[i] + dp[j] ) : a[i] )  ( j < i )

就是对于 i ,找到前 i-1 个中能跳到 i 的最大的dp(若都跳不到 i 那就是a[i]本身),即是dp[i]。


以下代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int a[1010],dp[1010],N,i,j;
	while(1)
	{
		scanf("%d",&N);
		if(N==0)
			break;
		memset(dp,0,sizeof(dp));
		for(i=1;i<=N;i++)
			scanf("%d",&a[i]);
		a[0]=0;
		for(i=1;i<=N;i++)
		{
			for(j=0;j<i;j++)
				dp[i]=max(dp[i],a[j]<a[i]?(a[i]+dp[j]):a[i]);
							    //利用三目运算符来判断
		}
		int ans=0;
		for(i=1;i<=N;i++)   //找到最大值
			ans=max(ans,dp[i]);
		printf("%d\n",ans);
	} 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ratina/article/details/84929510