暑假训练 Cash Machine POJ - 1276

题目描述:
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 … nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10

Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

code:
二进制优化求解:

#include<cstdio>
#include<iostream>
#include<string.h>
#include<cmath>
using namespace std;

const int max1 = 1e7+10;
const int max2 = 100005;
int nk[15], dk[max1], dp[max2];
int main()
{
    int cash, n, a, b;
    while(cin>>cash>>n)
    {
        memset(dp, 0, sizeof dp);
        for(int i = 0; i < n; i++)
            scanf("%d%d", &nk[i], &dk[i]);
        if(n == 0 || cash == 0){cout<<0<<endl;continue;}
        int k = n;
        for(int i = 0; i < n; i++)
        {
            if(nk[i] == 0){dk[i] = 0; continue;}
            int j = 2;
            while(j < nk[i])
            {
                dk[k++] = dk[i] * j;
                nk[i] -= j;
                j = 2 * j;
            }
            nk[i]--;
            if(nk[i] != 0)dk[k++] = nk[i]*dk[i];
        }
        for(int i = 0; i < k; i++)
        {
            for(int j = cash; j >= dk[i]; j--)
            {
                dp[j] = max(dp[j], dp[j-dk[i]]+dk[i]);
            }
        }
        cout<<dp[cash]<<endl;
    }
    return 0;
}

限制01背包次数求解

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;

const int max1=1e5+5;
const int max2=15;
int dp[max1];
int nk[max2], dk[max2];
int main()
{
    int cash, N;
    while(cin>>cash>>N)
    {
        for(int i = 1; i <= N; i++)
        {
            cin>>nk[i]>>dk[i];
        }
        if(cash == 0 || N == 0){cout<<0<<endl;continue;}
        memset(dp, -1, sizeof dp);
        for(int i = 1; i <= N; i++)
        {
            dp[0] = nk[i];
            for(int j = 1; j <= cash; j++)
            {
                if(dp[j] >= 0)dp[j] = nk[i];
                else if(dk[i] <= j)dp[j] = dp[j-dk[i]]-1;
            }
        }
        for(int j = cash; j >= 0; j--)
        {
            if(dp[j]>=0)
            {
                cout<<j<<endl;
                break;
            }
        }
    }
    return 0;
}

比较明显的多重背包了,二进制的方法感觉很精妙。
比如:11拆解为1+2+4+4,20拆解为1+2+4+8+5。。。
还有网上看到的背包专题:背包九讲

猜你喜欢

转载自blog.csdn.net/wbl1970353515/article/details/82938327