Cash Machine POJ - 1276 ( 多重背包 )

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/SEVENY_/article/details/83792487

Cash Machine

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

 题意:

给出金额cash,货币的种类n,然后给出每种货币的数量和金额。请找出利用这些货币可以凑成的最接近且小于等于给定的cash的金额。这个就是多重背包的问题,使用二进制化简为01背包。

二进制化简可以看此题的详解:https://blog.csdn.net/SEVENY_/article/details/82230252

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int dp[100009];
int val[100009];  //每种货币的价值
int main()
{
	int cash,n,v,c; 
	while(scanf("%d%d",&cash,&n)!=EOF) //给定的金额,货币的种类
	{
		memset(dp,0,sizeof(dp));
		int ind=0;  //将货币数量分解后,货币的种类数
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&c,&v);
			for(int j=1;c!=0;j*=2)  //二进制分解每种货币的数量
			{
				if(c>=j)
				{
					val[ind++]=j*v;
					c-=j;
				}
				else
				{
					val[ind++]=c*v;
					c=0;
				}
			}
		} 
		for(int i=0;i<ind;i++)
		{
			for(int j=cash;j>=val[i];j--)
			{
				dp[j]=max(dp[j],dp[j-val[i]]+val[i]);
				
			}
		}
		printf("%d\n",dp[cash]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SEVENY_/article/details/83792487