POJ 1276 Cash Machine(多重背包)

版权声明:本文为博主原创文章,欢迎转载。如有问题,欢迎指正。 https://blog.csdn.net/weixin_42172261/article/details/89631341

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 … nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

给出sum金钱和n种面值不同的钞票,然后是n组信息,分别是对应的数量和面值,求出在不超过sum的情况下,拿到的最大的价值。多重背包问题。
dp数组记录某一种价值是否可以成功兑换,i表示第i种面值,j表示j价值的金钱
一开始要把dp[0]=1,表示兑换0金钱是可以的。
再就是注意多重背包和01背包不像完全背包那样。因为每个物品有限,如果从左向右遍历的话,前面已经加上一件这个物品,到后面还可能会加上这个物品。所以必须从右向左遍历。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct node{
	int n, v;
}a[20];
int dp[100005];
int main()
{
	int sum, n;
	while (scanf("%d%d", &sum, &n)!=EOF){
		for (int i=1; i<=n; i++)
			scanf("%d%d", &a[i].n, &a[i].v);
		if (sum==0){
			printf("0\n");
			continue;
		}
		if (n==0){
			printf("0\n");
			continue;
		}
		memset(dp, 0, sizeof(dp));
		dp[0]=1;
		int maxx=0, tmp;
		for (int i=1; i<=n; i++){
			for (int j=maxx; j>=0; j--){
				if (dp[j]){
					for (int k=1; k<=a[i].n; k++){
						tmp=j+k*a[i].v;
						if (tmp>sum)
							continue;
						dp[tmp]=1;
						if (tmp>maxx)
							maxx=tmp;
					}
				}
			}
		}
		printf("%d\n", maxx);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42172261/article/details/89631341