E - Cash Machine

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no ca 

题目分析(背包问题变形): 

多重背包,给你一些钱,每一种钱有nk张,要求要你找出不超过cash的最大钱数。

相当于给你一个背包(容量为cash),有n种物品,每种物品有ni个。求背包的最大价值。

 思路一:

我们可以将每种物品分为k种,其中k=log(ni),每种物品的重量为1,2,4,……,2^k,ni-(2^(k+1)-1),然后对这些物品做0-1背包。

其中f[j]的含义为:如果为1,则表示前i种物品(货币)可以实现最大取值为j;为0,则表示不可以取到。

f[j] = f[j] || f[j-k*w[i]];

代码:

#include <queue>
#include <vector>
#include <cstdio>
#include <utility>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int cash,n,ans,w[1005],d[1005];
bool f[100005];
int main() {
	cin.sync_with_stdio(false);
	while(cin>>cash>>n) {
		memset(f,0,sizeof(f));
		f[0] = true;
		for(int i = 1; i <= n; i++){
			cin>>d[i]>>w[i];
			int k = 1;
			for(; d[i]-2*k+1 > 0; k*=2) {
				for(int j = cash; j >= k*w[i]; j--) 
				f[j] = f[j] || f[j-k*w[i]];//检测是否可以填满容量为j的背包 
			}//log(d[i])种背包 
			k = d[i]-k+1;//第i种物品的最后一种
			for(int j = cash; j >= k*w[i]; j--)  f[j] = f[j] || f[j-k*w[i]];
		}
		int j = cash;
		for(; j; j--) if(f[j]) break;//第一个不为0的即是最大值
		cout<<j<<endl;
	}
}

思路二:

《挑战程序设计竞赛》中给的方法,改变F[i][j]的含义,此时F[I][J]表示前i种物品得到j时最多能剩下几个i,那么就有

if(f[j] >= 0) f[j] = d[i];

else if(j >= w[i]) f[j] = f[j-w[i]] - 1; 

但是注意,f的取值可能为负值,负值的话就代表取不到,但是没有关系,我们关心的就是正值,这个并不影响。

#include <queue>
#include <vector>
#include <cstdio>
#include <utility>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int cash,n,ans,w[1005],d[1005],f[100005];
int main()
{
	cin.sync_with_stdio(false);
	while(cin>>cash>>n)
	{
		memset(f,-1,sizeof(f));
		for(int i = 1;i <= n;i++) 
            cin>>d[i]>>w[i];
		for(int i = 1;i <= n;i++)
		{
			f[0] = d[i];
			for(int j = 1;j <= cash;j++)
			{
				if(f[j] >= 0) f[j] = d[i];
				else 
				 if(j >= w[i]) f[j] = f[j-w[i]] - 1;
			}
		}
		ans = 0;
		for(int j = cash;j;j--)
		 if(f[j] >= 0) 
		 {
		 	ans = j;
		 	break;
		 }
		cout<<ans<<endl;
	}
}

参考文献:

1、https://blog.csdn.net/u014258433/article/details/51614734 

2、《挑战程序设计》

发布了43 篇原创文章 · 获赞 23 · 访问量 5320

猜你喜欢

转载自blog.csdn.net/weixin_43442778/article/details/90145402