POJ - 1276 Cash Machine 【多重背包(二进制拆分)】

                                                     Cash Machine

Time Limit: 1000MS   Memory Limit: 10000K

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

每行一组数据,第一个数sum,第二个数n代表有n对数n个物品,第i对第一个数字表示第i种物品有多少个,第二个数字wi表示一个第i件物品的价值。 问用这n种物品凑最接近sum(不超过sum)的值。

解题思路

多重背包二进制拆分板子题,(多重背包讲解 一搜一堆),背包容量即为最sum,第i个物品的价值和体积都为wi,求背包所能装下的最大价值。

AC Code

#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdio>
using namespace std;
const int maxn = 1e6+5;
int num[maxn],w1[maxn],c1[maxn],w[maxn],c[maxn];
int dp[maxn];
int main()
{
    int sum,n;
    while(~scanf("%d %d",&sum,&n)) {
        for(int i=1;i<=n;i++) {
            scanf("%d %d",&num[i],&w1[i]);
            c1[i] = w1[i];
        }
        int tot = 0;
        for(int i=1;i<=n;i++) {
            for(int j=1;j<=num[i];j<<=1) {
                w[++tot] = j*w1[i];
                c[tot] = j*c1[i];
                num[i] -= j;
            }
            if(num[i]!=0) {
                w[++tot] = num[i]*w1[i];
                c[tot] = num[i]*c1[i];
            }
        } 
        memset(dp,0,sizeof dp);
        for(int i=1;i<=tot;i++) {
            for(int j=sum;j>=c[i];j--) {
                dp[j] = max(dp[j],dp[j-c[i]]+w[i]);
            }
        }
        printf("%d\n",dp[sum]);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/89647227