POJ - 1276 - Cash Machine(多重背包)

POJ - 1276 - Cash Machine

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

就是银行取款,给你要取的金额,然后告诉你货币的种类和数量,让你求不大于所求钱数的值,看这些钱币最多能给出取款者多少钱。
这是个多重背包,每一种货币有数量,最后的值要求不大于所求值,也就是小于等于体积内取最大值。但是还不是套几个循环那么简单。我刚开始就是直接三个循环暴力了一下,结果就TLE了,这个需要二进制优化

for(int i = 0; i < k; i++)
{
scanf(“%d%d”, &n, &m);
for(int j = 1; j < n; j <<= 1)
{
a[++cnt] = j * m;
n -= j;
}
if(n > 0) a[++cnt] = n * m;
}

扫描二维码关注公众号,回复: 2813306 查看本文章

就是这一段代码,在输入的过程中将某个货币的数量提前乘好,分成几部分,作为新的物品开始放,这样就可以转化为01背包来做了。
AC代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
const int maxn = 1e5 + 5;
int dp[maxn];
int a[maxn];

int main()
{
    int v, k;
    int n, m;
    while(~scanf("%d%d", &v, &k))
    {
        int cnt = 0;
        memset(dp, 0, sizeof(dp));
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d", &n, &m);
            for(int j = 1; j < n; j <<= 1)
            {
                a[++cnt] = j * m;
                n -= j;
            }
            if(n > 0)   a[++cnt] = n * m;
        }
        if(!k || !v)
        {
            printf("0\n");
            continue ;
        }
        for(int i = 1; i <= cnt; i++)
        {
            for(int j = v; j >= a[i]; j--)
            {
                dp[j] = max(dp[j], dp[j - a[i]] + a[i]);
            }
        }
        printf("%d\n", dp[v]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40788897/article/details/81751050