HDU6227 Rabbits

Problem Description

Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position.
Help them play as long as possible

Input

The input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases.
For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers a1 < a2 < a3 < ... < aN which are the initial positions of the rabbits. For each rabbit, its initial position
ai satisfies 1 ≤ ai ≤ 10000.

Output

For each case, output the largest number of moves the rabbits can make.

Sample Input

5

3

3 4 6

3

2 3 5

3

3 5 9

4

1 2 3 4

4

1 2 4 5

Sample Output

1

1

3

0

1

思路

每只兔子跳向其之后的两只兔子之间能使跳跃的次数尽可能多

正着跳和反着跳,跳跃次数存在不同

代码

#include<stdio.h>
#include<algorithm>
using namespace std;
#define MAX 505
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,rab[MAX];
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
           scanf("%d",&rab[i]);
        }
        int ans_1=0;
        for(int i=0;i<n-2;i++)
        {
            if(rab[i+2]-rab[i+1]>1)
                ans_1+=rab[i+2]-rab[i+1]-1;
        }
        int ans_2=0;
        for(int i=n-1;i>=2;i--)
        {
            if(rab[i-1]-rab[i-2]>1)
               ans_2+=rab[i-1]-rab[i-2]-1;
        }
        printf("%d\n",max(ans_1,ans_2));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/83246264