HDU1711数组KMP

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

6

-1

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1711

#include<bits/stdc++.h>
using namespace std;
/*题目意思就是在长数组a里匹配短数组b,并且返回匹配成功的第一个元素在数组a中的   下标+1
这样问题就是寻找短数组b的next数组,然后在a里匹配*/
int a[1000005],b[10005],nxt[100005];//提醒一下C++中,用next命名数组会和系统库里定义产生模糊,所以用nxt
int n,m;
void getnext()
{
    nxt[0]=-1;
    int i=0,j=-1;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            j++,i++;
            /*if(b[i] == b[j])//这里是优化版kmp算法,不优化也可以通过
              nxt[i] = nxt[j];
            else*/
                nxt[i] = j;
/*这是我们典型的字符串中优化代码

            if (str2[i]!=str2[j])

                next[i] = j;

            else

                next[i] = next[j];
*/
        }
        else
        {
            j=nxt[j];
        }
    }

}

int kmp()
{
    int i=0,j=0;
    while(i<n)//边界条件肯定是下标i<数组a的长度
    {
        if(a[i]==b[j])//如果在a[i]==b[j]的情况下,而且j==m-1,说明短数组b匹配到头了,就是成功了
        {
            if(j==m-1)
                return i-j+1;//因为下标是从0开始的,所以加1
            i++;j++;
        }
        else//如果a[i]!=b[j],根据next数组更新j的值,注意,j==-1时,回到起点了,所以j=0,从下标0开始,但i++,这样即使每一次都失败,
        //但i始终++,只要i>=n了,循环结束,跳出循环,返回-1,失败
        {
            j=nxt[j];
            if(j==-1)
            {
                i++;
                j=0;
            }
        }
    }
    return -1;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<m;i++)
            scanf("%d",&b[i]);
        if(n<m)
            printf("-1\n");
        else
        {
            getnext();
            printf("%d\n",kmp());
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/salmonwilliam/article/details/82596296