hdu1711(kmp求第一个子串位置)(新)

http://acm.hdu.edu.cn/showproblem.php?pid=1711
Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 47015 Accepted Submission(s): 19035

Problem Description
Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output
6
-1

Source
HDU 2007-Spring Programming Contest

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1000002;
int nxt[maxn],TT,slen,tlen;
int S[maxn],T[maxn];
void getNxt()
{
    int i,j;
    i=0,j=-1,nxt[0]=-1;
    while(i<tlen)
    {
        if(j==-1||T[i]==T[j])
        {
            nxt[++i]=++j;
        }
        else
        {
            j=nxt[j];
        }
    }
}

int KMP_Index()
{
    int i=0,j=0;
    getNxt();
    while(i<slen&&j<tlen)
    {
        if(j==-1||S[i]==T[j])
        {
            i++;
            j++;
        }
        else
        {
            j=nxt[j];
        }
    }
    if(j==tlen)
    {
        return i-tlen;
    }
    else
        return -1;
}

int KMP_Count()
{
    int ans=0,i=0,j=0;
    if(slen==1&&tlen==1)
    {
        if(S[0]==T[0])
            return 1;
        else
            return 0;
    }
    getNxt();
    for(i=0;i<slen;i++)
    {
        while(j>0&&S[i]!=T[j])
        {
            j=nxt[j];
        }
        if(S[i]==T[j])
            j++;
        if(j==tlen)
        {
            ans++;
            j=nxt[j];
        }
    }
    return ans;
}
int main()
{
    scanf("%d",&TT);
    while(TT--){
    scanf("%d %d",&slen,&tlen);
    for(int i=0;i<slen;i++){
        scanf("%d",&S[i]);
    }
    for(int i=0;i<tlen;i++){
        scanf("%d",&T[i]);
    }
    int ans =KMP_Index();
    if(ans!=-1){
        cout << ans +1 <<endl;
    }else{
        cout <<-1<<endl;
    }

    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/w1304636468/article/details/89450571