hdu1711(初级KMP)

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 37965    Accepted Submission(s): 15716


 

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

 

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

 

Sample Output

 

6 -1

 

Source

HDU 2007-Spring Programming Contest

这次是数组而不是字符串,原理相同

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e6 + 5;
int a[maxn], b[maxn], nex[maxn];
int n, m;
void getNext()
{
    nex[0] = -1;
    int k = -1;

    for(int q = 1;q < n; q ++)
    {
        while(k > -1 && b[k+1] != b[q])
            k = nex[k];

        if(b[k+1] == b[q])
            k ++;

        nex[q] = k;
    }
}

int kmp()
{
    getNext();

    int k = -1;
    for(int i = 0;i < n;i ++)
    {
        while(k > -1 && b[k+1] != a[i])
            k = nex[k];

        if(b[k+1] == a[i])
            k ++;

        if(k == m - 1)
            return i - m + 1;
    }
    return -1;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);

    int t;
    cin >> t;
    while(t --)
    {

        cin >> n >> m;

        for(int i = 0;i < n;i ++)
            cin >> a[i];
        for(int i = 0;i < m;i ++)
            cin >> b[i];

        int ans = kmp();
        if(ans != -1)
            cout << ++ans << endl;
        else cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/soul_97/article/details/81239332