HDU1711

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
 
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
 
  
6 -1
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2222 1867 2203 1710 1671 


题意:给你两个数组,长度分别为(n,m);问第一次出现上面的数组和下面的数组完全相同的位置。


一道典型的KMP算法裸题,把数组看成字符串即可


#include<stdio.h>
#include<string.h>
int a[10010],b[1000010],la,lb,next[10010];
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<la)
    {
        if(a[i]==a[j]||j==-1)
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int kmp()
{
    int i=0,j=0;
    while(i<lb&&j<la)
    {
        if(b[i]==a[j]||j==-1)
        {
            i++;
            j++;
        }
        else
            j=next[j];
    }
    if(j>=la)
        return i-j+1;
    else
        return -1;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&lb,&la);
        for(i=0;i<lb;i++)
            scanf("%d",&b[i]);
        for(i=0;i<la;i++)
            scanf("%d",&a[i]);
        memset(next,0,sizeof(next));
        get_next();
        j=kmp();
        printf("%d\n",j);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37751662/article/details/68141257
今日推荐