PAT 1046 Shortest Distance

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Void_worker/article/details/82598255

1046 Shortest Distance(20 分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
​5
​​ ]), followed by N integer distances D
​1
​​ D
​2
​​ ⋯ D
​N
​​ , where D
​i
​​ is the distance between the i-th and the (i+1)-st exits, and D
​N
​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
​4
​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10
​7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

链接:

https://pintia.cn/problem-sets/994805342720868352/problems/994805435700199424

代码:

#include<cstdio>
using namespace std;

int main() {
    int i, n, sum = 0, m;
    int c1, c2, s1, s2;
    scanf("%d",&n);
    int a[n + 1], dis[n + 1];
    dis[1] = 0;
    for(i = 1; i <= n; ++i){
        scanf("%d", &a[i]);
        sum += a[i];
        dis[i + 1] = sum;
    }
    scanf("%d", &m);
    int c[m][2];
    for(i = 0; i < m; ++i){
        scanf("%d %d",&c[i][0], &c[i][1]);
    }
    for(i = 0; i < m; ++i){
        if(c[i][0] < c[i][1]){
            c1 = c[i][0];
            c2 = c[i][1];
        }
        else{
            c1 = c[i][1];
            c2 = c[i][0];
        }
        s1 = dis[c2] - dis[c1];
        s2 = sum - s1;
        if(s1 > s2){
            printf("%d\n", s2);
        }
        else printf("%d\n", s1);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/Void_worker/article/details/82598255