PAT A1046 Shortest Distance(20)

1046 Shortest Distance (20)(20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10^5^]), followed by N integer distances D~1~ D~2~ ... D~N~, where D~i~ is the distance between the i-th and the (i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10^4^), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7^.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output

3
10
7

 思路: 

               用数组dis[i]存放 1->i+1的距离(顺时针),

               dis[0]:    1->1的距离,   0

               dis[1]:    1->2的距离:  

               dis[i]:     1->i+1的距离

     输入两个点之后,将两个点的顺时针距离,和逆时针距离进行比较,最小的就是最短距离

也可以用#include <algorithm>里面的 min()函数求取最小值. 为了防止大数减小数出现负数,对结果可以进行取绝对值处理abs()

或者判断 left right 大小,if(left>right) swap(left,right);//交换他们的值然后做差

#include <stdio.h>
#include <algorithm>
using namespace std;
int main(){
	int N,dis[100000],temp,sum=0;
	scanf("%d",&N);
	for(int i=1;i<=N;i++){//dis[i]:存放1到i+1的距离(顺时针)
		scanf("%d",&temp);
		sum+=temp;
		dis[i]=sum;
	}
	int t,distance;
	int left,right,min_d;
	scanf("%d",&t);
	for(int i=0;i<t;i++){
		scanf("%d%d",&left,&right);
		distance=abs(dis[left-1]-dis[right-1]);
		min_d=min(distance,sum-distance);
		printf("%d\n",min_d);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40959340/article/details/81214544