A1046 Shortest Distance

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10^5^]), followed by N integer distances D~1~ D~2~ ... D~N~, where D~i~ is the distance between the i-th and the (i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10^4^), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7^.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include<stdio.h>
int main(){
    int n,sum=0,o,p,max,min,m,k=1;
    scanf("%d",&n);//确定一共有的点为5个
    int a[n],dis[n];//a[i]为出事两点
    for(int i=0;i<n+1;i++){
        dis[i]=sum;//初始化赋值dis都为sum
    }
    for(int i=1;i<n+1;i++){
        scanf("%d",&a[i]);//输入两点之间的距离,赋值给a[i]数组
        sum=sum+a[i];//总长度
    }
    scanf("%d",&m);//确定一共需要m个询问距离
    for(int j=0;j<m;j++){
        scanf("%d%d",&o,&p);//输入两个点的坐标
        if(o>=p){
            max=o;//求出大值
            min=p;//求出小值
        }
        if(o<p){
            max=p;//求出大值
            min=o;//求出小值
        }
        for(int i=min;i<max;i++){
                dis[k]=dis[k]+a[i];//求出从a[min]到a[max]之间的顺时针距离
        }
        if(dis[k]>=sum-dis[k])//比较a[min]到a[max]之间的顺时针与逆时针距离
            dis[k]=sum-dis[k];

        k++;//每次结束储存的k+1

    }
    for(int i=1;i<m+1;i++){
        printf("%d\n",dis[i]);//输出距离
    }
    return 0;
}

有点小问题,第三个测试点超时,求看到的大佬帮忙看下哪有问题!

猜你喜欢

转载自blog.csdn.net/weixin_42127158/article/details/80955320