PAT 甲级 1046 Shortest Distance

https://pintia.cn/problem-sets/994805342720868352/problems/994805435700199424

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10^5^]), followed by N integer distances D~1~ D~2~ ... D~N~, where D~i~ is the distance between the i-th and the (i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10^4^), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7^.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

代码:
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int a[maxn], dis[maxn];

int main() {
    int N, sum = 0;
    scanf("%d", &N);
    for(int i = 1; i <= N; i ++) {
        scanf("%d", &a[i]);
        sum += a[i];
        dis[i] = sum;
    }

    int T, left, right, temp;
    scanf("%d", &T);
    for(int i = 1; i <= T; i ++) {
        scanf("%d%d", &left, &right);
        if(left > right) {
            swap(left, right);
        }
        temp = dis[right - 1] - dis[left - 1];
        printf("%d\n", min(temp, sum - temp));
    }

    return 0;
 }

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9439663.html