[A] 1046 Shortest Distance

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7


晚上被这道题坑了很久,一直没想明白为什么不能完全ac,只能拿17/20的分,,我一开始的想法是每次都一个循环遍历相加来求距离,查了网上资料说,在极端情况下,每次查询都需要遍历整个数组,即有1e5次操作,而共有1e4次查询,所以极端情况下会有1e9次操作,这在100ms内往往会超时。
解决办法是一开始设置一个dis[i]表示1号结点顺时针方向到达i号结点的下一个结点的距离,这样在输入时就可以直接得到dis,因此查询复杂度可以直接达到o(1),这样就好了orz.。。

#include<cstdio>

using namespace std;

#define MAX 100001

int dis[MAX] , a[MAX];

int main(void){
    int sum = 0;
    int n,m,v1,v2;
    scanf("%d",&n);
    for(int i = 1; i <= n; i++){
        scanf("%d",&a[i]);
        sum += a[i];
        dis[i] = sum;
    }
    
    scanf("%d",&m);
    while(m--){
        scanf("%d %d",&v1,&v2);
        if(v1 > v2){
            int t = v1;
            v1 = v2;
            v2 =t;
        }
        
        int ans = dis[v2-1] - dis[v1-1];
        if(ans > (sum-ans) )
            ans = sum -ans;
        printf("%d\n",ans);
    }

    
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/hish/p/10247460.html