PAT甲级--1046 Shortest Distance(20 分)

1046 Shortest Distance(20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

解题 思路:这题比较简单,直接看代码就懂了。

#include<bits/stdc++.h>
using namespace std;
int a[100010],dis[100010];
int main(void)
{
	int n;
	scanf("%d",&n);
	memset(dis,0,sizeof dis);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		dis[i+1]=dis[i]+a[i];
	} 
	int sum=dis[n+1];
	int m;
	scanf("%d",&m);
	while(m--)
	{
		int l,r;
		scanf("%d%d",&l,&r);
		if(l>r) swap(l,r);
		int temp=dis[r]-dis[l];
		printf("%d\n",min(temp,sum-temp));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82119010