【PAT A1046】Shortest Distance

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

#include <stdio.h>

int main() {
    int a1ToOtherDis[100] = {0}, N, sum = 0, len[100], questionNum, left, right, shun, ni;
    scanf("%d", &N);
    for (int i = 1; i <= N; i++) {

        scanf("%d", &len[i]);
        sum = sum + len[i];
        a1ToOtherDis[i] = sum;

    }
    scanf("%d", &questionNum);
    for (int i = 0; i < questionNum; i++) {
        scanf("%d%d", &left, &right);
        //保证 left<right
        if (left > right) {
            int temp = left;
            left = right;
            right = temp;
        }
        //顺时针
        shun = a1ToOtherDis[right - 1] - a1ToOtherDis[left - 1];
        ni = sum - shun;
        if (shun < ni)
            printf("%d\n", shun);
        else
            printf("%d\n", ni);
    }
}
/*
5 1 2 4 14 9
3
1 3
2 5
4 1
*/

测试结果:
在这里插入图片描述

发布了33 篇原创文章 · 获赞 1 · 访问量 4143

猜你喜欢

转载自blog.csdn.net/qq_39827677/article/details/103862244